Symptom
Despite having a voicemail configured on Aircall's previous routing (for Smartflows please see My voicemail widget is active, but callers cannot leave messages), some calls are marked as missed with no voicemail, even though users expect there should be messages left.
Cause
There could be several causes for not receiving voicemails on certain missed calls, including:
- The voicemail option is not toggled on for certain numbers (Configuring Numbers: Voicemail, Music, and Messages)
- Users are hanging up before leaving a message
However, it is also important to note that voicemails will not be saved if they are under 5 seconds long or over 4 hours long. If a caller mistakenly stays connected to the voicemail for more than 4 hours, that voicemail will not show in Aircall. Similarly, if a caller leaves a very brief message, such as "call me back," it also will not show in Aircall if it is under 5 seconds.
Solution
To ensure that all voicemails are saved in Aircall, please make sure that the voicemail option is toggled on and that callers are aware that they will need to leave a message between 5 seconds and 4 hours long.
If necessary, a notice can be incorporated into the message you designate before the voicemail, to ensure customers are leaving appropriately long messages.