The Voicemail widget allows callers to leave a message that is sent to all users associated with the call distribution where the widget is placed. This ensures that no message is missed and that the right users or teams can access voicemail recordings directly in their Aircall app.

How the Voicemail widget works

When callers reach the Voicemail step in your Smartflow, they will hear a recorded message (either uploaded, recorded, or generated using text-to-speech) prompting them to leave a voicemail. The voicemail is then delivered to all users or teams linked to that number’s distribution.

Important: If no users are connected to a number with a Voicemail widget, no one will receive voicemails in their app.
At least one user or team must be linked to that number.

If you want users to receive only voicemails (and not incoming calls), you can add them to the Call data and access list. This gives them access to voicemail messages without including them in the live call distribution.

Widget configuration options

You can customize the voicemail message your callers hear using one of the following methods:

Text to speech

You can write your message and select the preferred voice and language. Remember to preview the result before publishing.

Voice speed cannot be adjusted, but each available voice has a natural variation in pace. For example, US English voices Ivy and Joanna are slightly faster than Matthew, and both are faster than Joey.

Custom fileYou can upload a pre-recorded audio file in MP3 format if you already have a custom voicemail message.
Record audioYou can record your own message directly within the widget if you do not wish to use text-to-speech or an uploaded file.

Maximum message duration

Set how long callers can record their message. It is recommended to allow up to 3 minutes so callers can leave a complete message.

Note: Any widgets placed after a Voicemail widget will be ignored. Once a voicemail is recorded, the call ends automatically.

Callers unable to leave a voicemail

Symptom

Callers reach the Voicemail widget, hear the greeting, but are disconnected before leaving a message.

Cause

To prevent blank messages, the Voicemail widget automatically disconnects the call if:

  • There is no audible message being left in the first 5 seconds after the voicemail message is played.
  • The caller pauses for more than 5 seconds while recording.

For example, if a caller begins speaking but stops for 5 seconds or longer, the recording will end and the call will disconnect.

Solution

To ensure that all callers are getting the opportunity to leave a voicemail, please make sure that callers are aware that they will need to begin leaving their message within 5 seconds, and should not pause for longer than 5 seconds after they have begun.

If necessary, a notice can be incorporated into the Voicemail Message you designate for the widget, to ensure customers are promptly leaving their voicemail.