Parfois, vous pouvez avoir besoin de supprimer un seul composant de votre flux de distribution d'appels. Cependant, la suppression d'un composant peut également entraîner la suppression de toutes les étapes qui le suivent. Cet article explique pourquoi cela se produit et comment supprimer en toute sécurité un composant sans perdre les étapes en aval.

Symptôme

Lors de la suppression d'un composant dans le flux de distribution d'appels, tous les composants suivants qui y sont connectés sont également supprimés.

Cause

Le flux de distribution d'appels d'Aircall est conçu comme une séquence linéaire. Chaque composant dépend de celui qui le précède. Lorsqu'un composant est supprimé, toutes les étapes qui le suivent sont considérées comme dépendantes et sont donc supprimées.

Solution

Pour supprimer un composant individuel sans supprimer les étapes suivantes, suivez les étapes ci-dessous.

Étapes :

  1. Allez dans Tableau de bord Aircall > Numéros.
  2. Ouvrez le Numéro que vous souhaitez configurer et allez dans l'onglet Distribution des appels.
  3. Identifiez le composant que vous souhaitez supprimer. Dans l'exemple, un widget Règle de date est utilisé.
  4. Avant de supprimer le widget Règle de date, copiez et collez les étapes situées au-dessus vers un emplacement sûr qui ne sera pas affecté.
    • Cliquez sur l'étape que vous souhaitez copier, par exemple Règle de temps.
    • Sélectionnez l'option pour copier l'étape.
    • Collez l'étape au-dessus du widget Règle de date.
  5. Une fois l'étape dupliquée avec succès, supprimez le widget Règle de date à la fin de la distribution des appels.
  6. Poursuivez toute configuration supplémentaire selon vos besoins.
CONSEIL :
Dupliquer les étapes avant de supprimer garantit que le flux reste intact et évite la perte accidentelle de la logique de routage.