Si vous voyez le message d'erreur « Contenu bloqué. Contactez le propriétaire du site pour résoudre le problème. » lors de l'utilisation d'Aircall CTI dans Salesforce, cela indique généralement un problème de configuration au sein des paramètres de sécurité de Salesforce.
Symptôme
Lors de la tentative d'utilisation d'Aircall CTI dans Salesforce, les utilisateurs rencontrent le message suivant : "Contenu bloqué. Contactez le propriétaire du site pour résoudre le problème."
Cause
Ce problème survient parce qu'une configuration de URL de confiance est manquante dans Salesforce. Sans ce paramètre, Salesforce bloque le contenu provenant des domaines Aircall dans le cadre de ses contrôles de sécurité.
Solution
Suivez ces étapes pour résoudre le problème :
Étapes :
- Allez dans la console Salesforce > Configuration
- Recherchez URLs de confiance.
- Cliquez sur Nouvelle URL de confiance.
- Dans le champ Nom API, saisissez Aircall.
-
Dans le champ URL, saisissez :
https://*.aircall.io
- Cochez toutes les cases dans la section Directives CSP.
- Cliquez sur Enregistrer.
- Rechargez la page Salesforce.
- Videz le cache de votre navigateur et reconnectez-vous à Salesforce.
Après avoir suivi ces étapes, le problème de blocage du contenu devrait être résolu.
Important: :
Si le problème persiste, vérifiez que vos paramètres réseau et pare-feu autorisent les connexions aux domaines Aircall :
https://*.aircall.io
Informations supplémentaires
Pour plus de détails sur la configuration de votre Aircall CTI dans Salesforce, consultez Comment configurer votre Aircall CTI dans Salesforce Lightning.
Assurez-vous également que les adresses e-mail des utilisateurs correspondent entre Salesforce et Aircall afin de maintenir une intégration correcte.