REMARQUE :
Cet article s'adresse à un public technique tel que les administrateurs informatiques.

Lorsque vous utilisez ZScaler dans votre environnement réseau, vous pouvez rencontrer des problèmes empêchant Aircall de se connecter correctement. Cet article décrit les symptômes, la cause et les modifications de configuration ZScaler requises.

Symptôme

Lorsque vous essayez d'utiliser Aircall dans un environnement réseau avec ZScaler, les utilisateurs ne parviennent pas à connecter Aircall.

Cause

Aircall ne prend pas en charge le Certificate Pinning.

Solution

En plus d'autoriser la liste habituelle des domaines, sous-réseaux et ports d'Aircall via votre pare-feu ou solution de sécurité des terminaux (voir notre article de la base de connaissances Pare-feux, antivirus et bloqueurs de contenu), lors de l'utilisation de ZScaler, vous devez également vous assurer que :

  • le Certificate Pinning est désactivé
  • l'inspection SSL est désactivée

Configuration ZScaler

Certificate Pinning
Le certificate pinning consiste à associer un certificat SSL ou TLS spécifique à un domaine particulier. Lorsqu'il est activé, ZScaler contourne l'inspection SSL pour le trafic chiffré avec des certificats épinglés, garantissant ainsi l'intégrité et la sécurité de ces connexions. Ceci est important pour les services ou applications qui nécessitent le certificate pinning à des fins d'authentification ou de sécurité.

Inspection SSL
L'inspection SSL, également appelée déchiffrement SSL ou TLS ou interception SSL ouchiffrer et à inspecter le trafic chiffré transitant par le réseau ZScaler. Dans certains cas, tels que les exigences de conformité ou les besoins spécifiques d'une application, il peut être nécessaire de désactiver l'inspection SSL. Cela garantit que le trafic chiffré reste opaque pour ZScaler, préservant ainsi le chiffrement de bout en bout pour les données sensibles.

La documentation fournie par ZScaler ici fournit plus de détails.