Wenn Sie die Fehlermeldung „Inhalt ist blockiert. Wenden Sie sich an den Websitebesitzer, um das Problem zu beheben.“ sehen, während Sie das Aircall CTI in Salesforce verwenden, deutet dies normalerweise auf ein Konfigurationsproblem in den Salesforce-Sicherheitseinstellungen hin.

Symptom

Beim Versuch, das Aircall CTI in Salesforce zu verwenden, erhalten Benutzer die folgende Meldung: „Inhalt ist blockiert. Wenden Sie sich an den Websitebesitzer, um das Problem zu beheben.

Ursache

Dieses Problem tritt auf, weil eine Vertrauenswürdige URL-Konfiguration in Salesforce fehlt. Ohne diese Einstellung blockiert Salesforce Inhalte von Aircall-Domains als Teil seiner Sicherheitskontrollen.

Lösung

Führen Sie die folgenden Schritte aus, um das Problem zu beheben:

Schritte:

  1. Gehen Sie zu Salesforce > Setup-Konsole
  2. Suchen Sie nach Vertrauenswürdige URLs.
  3. Klicken Sie auf Neue Vertrauenswürdige URL.
  4. Geben Sie im Feld API-Name Aircall ein.
  5. Geben Sie im Feld URL Folgendes ein:

    https://*.aircall.io
    
  6. Aktivieren Sie alle Kästchen im Abschnitt CSP-Richtlinien.
  7. Klicken Sie auf Speichern.
  8. Laden Sie die Salesforce-Seite neu.
  9. Leeren Sie den Cache Ihres Browsers und melden Sie sich erneut bei Salesforce an.

Setup console in Salesforce and where to find the API Fielf, URL, etc.

Nach Abschluss dieser Schritte sollte das Problem mit der Inhaltsblockierung behoben sein.

WICHTIG:
Wenn das Problem weiterhin besteht, überprüfen Sie, ob Ihre Netzwerk- und Firewall-Einstellungen Verbindungen zu Aircall-Domains zulassen:
https://*.aircall.io

Zusätzliche Informationen

Für weitere Details zur Einrichtung Ihres Aircall CTI in Salesforce lesen Sie bitte Wie Sie Ihr Aircall CTI innerhalb von Salesforce Lightning konfigurieren.
Stellen Sie außerdem sicher, dass die E-Mail-Adressen der Benutzer zwischen Salesforce und Aircall übereinstimmen, um eine ordnungsgemäße Integration zu gewährleisten.