Symptom
When using the Aircall-HubSpot integration, some calls logged by Aircall are associated with Tickets or Contacts that are not related to the call.
Cause
Some calls being associated with Tickets or Contacts that are not related to the call can occur when Automatic Associations are turned on in HubSpot.
Solution
Checking the Association Update Source
First, you’ll need to confirm if that association is occurring through the Aircall-HubSpot integration, or if the association is occurring via “Internal Automation” after the call is logged in HubSpot:
- In HubSpot, locate the Contact or Ticket where the call was incorrectly associated
- Go to Actions > View Association History
- Under the Object dropdown, select Call
- Locate the Call association event in the list and check if the Source is “Updated via API”
- Updates made via the Aircall-HubSpot integration will be listed as “Updated via API”
- Updates made in HubSpot will be listed as “Internal Automation”
Turning Off Automatic Associations
If you confirm the associations are happening via “Internal Automation”, this is most likely related to HubSpot’s Automatic Association feature. We suggest turning that feature off using these steps:
- In HubSpot, go to Settings > Tools > Calling > Automatic Associations
- Uncheck the box for Link associated objects to recorded calls with HubSpot AI
If the issue continues after turning off Automatic Associations, please contact our Support team for assistance.