Symptom
HubSpot has it's own reporting for agent and call statistics. Sometimes the statistics do not match when compared to Aircall Reporting.
Cause
This mismatch is often expected because the calculations done in the background by Aircall and HubSpot will be different. There is no direct communication between Aircall reporting and HubSpot reporting.
For example: the HubSpot stats for the number of calls for an Agent sometimes do not match the Aircall stats of the same agent's calls.
- This particular discrepancy is because missed calls and voicemails don't get associated with any user in Aircall
- Other agents or supervisors can later see those missed calls and voicemails in their call history and manually assign it to an agent, which HubSpot reports consider as a call activity and records it as a call for that Agent in the HubSpot stats
Solution
When comparing HubSpot and Aircall reporting, it's important to keep in mind the expected differences in how certain statistics are calculated so that you can avoid any confusion with different results.