Symptom:
iOS constantly switches between Wi-Fi and Cellular data, causing Aircall to lose connection.
Cause:
Apple iOS 9 and up has a feature called Wi-Fi Assist, which is on by default. When your iPhone detects a poor Wi-Fi signal, it will automatically switch to a cellular data connection.
Solution:
- Go to Settings > Mobile/Cellular Service
- Open the Settings app and tap Mobile Service. Depending on your region, you may see Cellular, Cellular Service, Cellular Data, or Mobile Data
- Toggle off Wi-Fi Assist
Scroll down (you'll need to go down quite a way, past all the individual apps) and toggle off Wi-Fi Assist.