Whenever you receive an inbound call in Aircall, you might notice that all your open Salesforce tabs automatically switch to the contact page of that inbound call. This article explains why that happens and how to change the related setting.
Symptom
Whenever you receive an inbound call, all your open Salesforce tabs automatically switch to the Contact page of that inbound call.
Cause
This behavior is the result of a setting that has been configured for your Salesforce integration, allowing for a pop up of the Contact page when a call has been received:
Note: This setting is responsible for Salesforce opening or switching to the contact page when your phone rings.
Solution
This setting can be disabled by an Admin through the Aircall Dashboard.
Steps:
Select your Salesforce integration.
Click on Settings and scroll down to Salesforce Settings.
Modify the setting "Pop up of contact page when it rings".
Important: You will need to change this setting for each Salesforce integration you have.
Note: Once you change this setting, you will not have the contact page pop up at all for any calls.