HINWEIS:
Dieser Artikel richtet sich an technische Zielgruppen wie IT-Administratoren.

Bei der Verwendung von ZScaler in Ihrer Netzwerkumgebung können Probleme auftreten, die verhindern, dass Aircall korrekt eine Verbindung herstellt. Dieser Artikel beschreibt die Symptome, die Ursache und die erforderlichen ZScaler-Konfigurationsänderungen.

Symptom

Beim Versuch, Aircall in einer Netzwerkumgebung mit ZScaler zu verwenden, können Benutzer keine Verbindung zu Aircall herstellen.

Ursache

Aircall unterstützt Certificate Pinning nicht.

Lösung

Zusätzlich zur Freigabe der üblichen Liste von Aircall Domains, Subnetzen und Ports durch Ihre Firewall oder Endpoint-Sicherheitslösung (siehe unseren KB-Artikel Firewalls, Antivirenprogramme und Inhaltsblocker), müssen Sie bei der Verwendung von ZScaler ebenfalls sicherstellen, dass:

  • Certificate Pinning deaktiviert ist
  • SSL-Inspektion deaktiviert ist

ZScaler-Konfiguration

Certificate Pinning
Certificate Pinning beinhaltet die Zuordnung eines bestimmten SSL- oder TLS-Zertifikats zu einer bestimmten Domain. Wenn aktiviert, umgeht ZScaler die SSL-Inspektion für mit gepinnten Zertifikaten verschlüsselten Datenverkehr, wodurch die Integrität und Sicherheit dieser Verbindungen erhalten bleibt. Dies ist wichtig für Dienste oder Anwendungen, die Certificate Pinning für Authentifizcke erfordern.

SSL-Inspektion
Die SSL-Inspektion, auch bekannt als SSL- oder TLS-Entschlüsselung oder SSL- oder TLS-Interception, beinhaltet das Entschlüsseln und Überprüfen von verschlüsseltem Datenverkehr, der durch das ZScaler-Netzwerk läuft. In einigen Fällen, wie z. B. bei Compliance-Anforderungen oder speziellen Anwendungsbedürfnissen, muss die SSL-Inspektion möglicherweise deaktiviert werden. Dies stellt sicher, dass verschlüsselter Datenverkehr für ZScaler undurchsichtig bleibt und die Ende-zu-Ende-Verschlüsselung für sensible Daten erhalten bleibt.

Die von ZScaler bereitgestellte Dokumentation finden Sie hier mit weiteren Details.