Der Smartflows-Editor enthält ein integriertes Fehler- und Warnkontrollsystem, das sicherstellt, dass Ihre Anrufabläufe vor der Veröffentlichung korrekt konfiguriert sind. Dieses System hilft, unvollständige Abläufe zu vermeiden, sodass Sie ein besseres Anruferlebnis schaffen können.
Verstehen des Fehler- und Warnsystems
Beim Bearbeiten eines Ablaufs sehen Sie ein Symbol neben der Veröffentlichen-Schaltfläche in der oberen rechten Ecke des Editors. Dieses Symbol zeigt an, ob Ihr Ablauf Probleme enthält:
- Ein gelbes Ausrufezeichen (!) Symbol zeigt Warnungen an.
- Ein rotes Kreuz (x) Symbol zeigt Fehler an.
Die neben dem Symbol angezeigte Zahl gibt die Gesamtanzahl der Warnungen oder Fehler in Ihrem Ablauf an.
Warnungen
Warnungen informieren Sie über Konfigurationen, die möglicherweise nicht zum Scheitern Ihres Ablaufs führen, aber das Anruferlebnis beeinträchtigen könnten.
- Ein gelbes Ausrufezeichen (!) Symbol erscheint neben der Veröffentlichen-Schaltfläche, wenn Warnungen erkannt werden.
- Klicken Sie auf das Symbol, um eine Liste der Warnungen anzuzeigen.
- Wählen Sie eine Warnung aus, um das entsprechende Widget in Ihrem Anrufablauf hervorzuheben.
Sie können Ihren Anrufablauf veröffentlichen, ohne die Warnungen zu beheben; es wird jedoch dringend empfohlen, diese zu überprüfen und zu korrigieren, um ein optimales Verhalten und Anruferlebnis sicherzustellen.
Fehler
Fehler weisen auf fehlende oder ungültige Konfigurationen hin, die verhindern, dass Ihr Anrufablauf korrekt funktioniert.
- Ein rotes Kreuz (x) Symbol erscheint neben der Veröffentlichen-Schaltfläche, wenn Fehler erkannt werden.
- Klicken Sie auf das Symbol, um detaillierte Informationen zu jedem Fehler anzuzeigen.
- Wählen Sie einen Fehler aus, um das betroffene Widget hervorzuheben.
Sie müssen alle Fehler beheben, bevor Sie Ihren Ablauf veröffentlichen können.
Achtung: Abläufe mit Fehlern können erst veröffentlicht werden, wenn alle Fehler behoben sind.
Häufige Warnung: „Zweig ohne Schritte“
Eine der häufigsten Smartflows-Warnungen ist die Meldung Zweig ohne Schritte. Diese Warnung kann unter verschiedenen Namen erscheinen, darunter:
- Zweig ohne Schritte
- IVR-Zweig „Keine oder falsche Eingabe“ ist nicht korrekt eingerichtet
Ursache
Diese Warnung zeigt an, dass einer Ihrer Ablaufzweige (zum Beispiel ein „Keine oder falsche Eingabe“-Zweig in einem IVR oder ein „Zu jeder anderen Zeit“-Zweig in einer Zeitregel) keine Widgets enthält.
Auswirkung
Dies ist nur eine Warnung, kein Fehler. Der betroffene Zweig wird während des Anrufablaufs einfach ignoriert, was bedeutet, dass Anrufer nicht über diesen Zweig weitergeleitet werden oder eine Nachricht hören.
Lösung
Wenn Sie die Warnung entfernen oder den Zweig aktiv machen möchten:
- Öffnen Sie den Zweig, der die Warnung anzeigt.
- Fügen Sie ein Widget hinzu, wie z. B. Audio, Voicemail oder Anrufen an, um zu definieren, was in diesem Pfad passieren soll.
Sobald ein Widget hinzugefügt wurde, verschwindet die Warnung.
Tipp: Obwohl Warnungen die Veröffentlichung nicht blockieren, sorgt deren Behebung für ein reibungsloseres und vorhersehbareres Anruferlebnis.