Symptôme
Lorsque vous tentez d'initier un appel sortant via l'API publique d'Aircall en utilisant le point de terminaison /v1/users/:id/calls
, comme décrit dans https://developer.aircall.io/api-references/#start-an-outbound-call , vous recevez une réponse positive pour la demande, mais aucun appel n'est initié.
Cause
Ce problème peut se produire en raison de l'exigence selon laquelle l'agent pour l'appel doit être dans un état disponible sur l'application de bureau d'Aircall. Si l'agent n'est disponible que sur l'application mobile, il peut être défini comme disponible et aucune réponse d'erreur n'est reçue, mais aucun appel n'est lancé car il n'est pas disponible sur desktop.
Solution
Pour éviter tout problème, assurez-vous que les utilisateurs appropriés utilisent toujours l'application Aircall Desktop si vous avez l'intention de lancer des appels par le biais de l'API publique.