Symptôme
Les utilisateurs rencontrent un message d'erreur indiquant « Le contenu est bloqué. Contactez le propriétaire du site pour résoudre le problème » lorsqu'ils tentent d'utiliser Aircall CTI dans Salesforce.
Cause
Ce problème est principalement dû à une configuration d'URL de confiance manquante dans Salesforce. Cela entraîne le blocage du contenu d'Aircall CTI par les paramètres de sécurité de Salesforce.
Solution
Veuillez suivre les étapes ci-dessous pour résoudre le problème :
- Connectez-vous à votre compte Salesforce.
- Recherchez et cliquez sur URL de confiance dans la console de configuration de Salesforce.
- Cliquez sur Nouvelle URL de confiance .
- Dans le champ Nom de l'API, saisissez Aircall .
- Dans le champ URL, saisissez
https://*.aircall.io
. - Cochez toutes les cases dans la section Directives CSP.
- Cliquez sur Enregistrer .
- Rechargez la page Salesforce.
Après avoir effectué ces étapes, videz le cache de votre navigateur et reconnectez-vous à Salesforce. Cela devrait résoudre le problème de blocage de contenu.
Informations supplémentaires
Pour plus d'informations sur la configuration d'Aircall CTI dans Salesforce, consultez Comment configurer votre CTI Aircall dans Salesforce Lightning . De plus, assurez-vous que les adresses e-mail des utilisateurs de Salesforce et d'Aircall correspondent pour une intégration correcte. Si le problème persiste, vous pouvez vous assurer que tous les paramètres réseau et de pare-feu autorisent les connexions aux domaines Aircall https://*.aircall.io
.