Síntoma
Al intentar iniciar una llamada saliente a través de la API pública de Aircall utilizando el punto final /v1/users/:id/calls
, como se describe en https://developer.aircall.io/api-references/#start-an-outbound-call , se recibe una respuesta de éxito para la solicitud, pero no se inicia ninguna llamada.
Causa
Este problema puede producirse debido al requisito de que el agente para la llamada debe estar en estado disponible en la aplicación de escritorio de Aircall. Si el agente sólo está disponible en la aplicación móvil, puede establecerse como disponible y, por lo tanto, no se recibe ninguna respuesta de error, pero no se inicia ninguna llamada porque no está disponible en escritorio.
Solución
Para evitar problemas, asegúrese de que los usuarios adecuados utilicen siempre la aplicación Aircall Desktop si desea iniciar llamadas a través de la API pública.