Síntoma
Los usuarios reciben un mensaje de error que indica: "Contenido bloqueado. Contacte al propietario del sitio para solucionar el problema" al intentar usar Aircall CTI en Salesforce.
Causa
Este problema se debe principalmente a la falta de una configuración de URL de confianza en Salesforce. Esto provoca que la configuración de seguridad de Salesforce bloquee el contenido de Aircall CTI.
Solución
Siga los pasos a continuación para resolver el problema:
- Inicie sesión en su cuenta de Salesforce.
- Busque y haga clic en URL de confianza en la consola de configuración de Salesforce.
- Haga clic en Nueva URL de confianza .
- En el campo Nombre de la API, escriba Aircall .
- En el campo URL, escriba
https://*.aircall.io
. - Marque todas las casillas en la sección Directivas de CSP.
- Haga clic en Guardar .
- Vuelva a cargar la página de Salesforce.
Después de realizar estos pasos, borre la caché de su navegador y vuelva a iniciar sesión en Salesforce. Esto debería resolver el problema de bloqueo de contenido.
Información adicional
Para obtener más información sobre la configuración de Aircall CTI en Salesforce, consulte Cómo configurar su Aircall CTI en Salesforce Lightning . Además, asegúrese de que los correos electrónicos de los usuarios coincidan entre Salesforce y Aircall para una correcta integración. Si el problema persiste, puede asegurarse de que la configuración de red y firewall permita conexiones a dominios de Aircall https://*.aircall.io
.