Síntoma
Cuando las personas que llaman intentan marcar por extensión para comunicarse con un agente específico, las extensiones funcionan en algunos números, pero no en otros. Las personas que llaman pueden escuchar un mensaje que dice "la extensión que marcó no existe".
Causa
La causa de que las extensiones funcionen en algunos números, pero no en otros, a menudo puede atribuirse a cómo las diferentes enrutamientos y distribuciones de llamadas manejan las extensiones.
Enrutamiento anterior ( Descripción del enrutamiento de llamadas )
Al utilizar nuestro enrutamiento anterior/heredado, las extensiones se comportarán de la siguiente manera:
- Para un número clásico, las extensiones se pueden marcar durante el mensaje de bienvenida y solo llegarán a los usuarios asignados a la distribución de llamadas de ese número específico. Las extensiones marcadas para usuarios no asignados a la distribución no se realizarán.
- Para un número IVR, las extensiones se pueden marcar en el mensaje de bienvenida o en el mensaje IVR y llegarán a cualquier usuario asignado a cualquier distribución de llamadas. Incluso si a un usuario no se le atribuye el número IVR de ninguna manera, si se marca su extensión, la llamada se enrutará a él.
Para nuestro enrutamiento anterior/heredado, las extensiones de usuario no funcionarán si la persona que llama marca una extensión en un número clásico y el usuario al que se marca no está asignado a la distribución de llamadas.
Enrutamiento de Smartflows ( Comprensión del enrutamiento de llamadas de Smartflows )
Al utilizar el enrutamiento Smartflows, las extensiones se comportarán de la siguiente manera:
- Las extensiones solo se pueden marcar durante un widget de audio y no funcionarán cuando se marquen durante un widget IVR.
- Las extensiones solo llegarán a los usuarios asignados a la distribución de llamadas de ese número específico. Las extensiones marcadas para usuarios no asignados a la distribución no se realizarán.
A diferencia del enrutamiento anterior/heredado, las extensiones de usuario no funcionarán cuando se marquen durante un mensaje IVR y solo se conectarán con los usuarios asignados a la distribución en todos los casos.
Solución
Para garantizar que las extensiones puedan funcionar para todos los usuarios en las situaciones necesarias, asegúrese de tener en cuenta los comportamientos anteriores al crear y editar sus distribuciones de llamadas.
Para números heredados, asegúrese de que todos los usuarios a los que será necesario comunicarse a través de una extensión estén asignados a la distribución de llamadas de cualquier número clásico al que se puedan marcar extensiones.
Para los números de Smartflow, asegúrese de que todos los usuarios a los que será necesario comunicarse a través de una extensión estén asignados a la distribución de llamadas para todos los números a los que se puedan marcar las extensiones. También puede considerar ajustar el flujo de cualquier número de IVR para redirigir a Equipos y Usuarios en lugar de Números.
Por ejemplo, si un número de Smartflows tiene la opción 1 que conduce a la línea de Ventas y la opción 2 que conduce a la línea de Soporte, si se marca cualquiera de los números de los agentes de Ventas o Soporte durante el mensaje de audio inicial, sus extensiones no trabajar. Si el flujo se actualizó para que la opción 1 condujera a un equipo de ventas y la opción 2 condujera a un equipo de soporte, entonces cualquier extensión marcada a un miembro de los equipos de ventas o soporte funcionaría.
Si es necesario mantener el IVR configurado para dirigir a los números de ventas y soporte, las extensiones deberán marcarse después de que la llamada haya sido redirigida a una de esas líneas, donde los usuarios están asignado a la distribución.