Symptom
Calls are not getting assigned to users, and the Related To/ Name fields are blank
Cause
It is possible that the Aircall_PermissionSet has not been assigned to the user experiencing the issue and/or to the user who has installed the integration.
Solution
- Go to Setup in Salesforce
- In the Quick Find box, type Users and select Users
- Find and click on the user you want to check
- Scroll down to the Permission Set Assignments related list on the user’s detail page
- Look for Aircall_permission set in the list. If it’s listed, the permission set is assigned to the user
If this permission set is not assigned please follow below step to assign this permission set.
- Go to Setup in Salesforce
- In the Quick Find box, type Users and select Users
- Find and click on the user to whom you want to assign the permission set
- Scroll down to the Permission Set Assignments related list on the user’s detail page.
- Click Edit Assignments
- In the Available Permission Sets list, find and select Aircall_permission set
- Click Add to move it to the Enabled Permission Sets list, then click Save
After taking the troubleshooting steps mentioned earlier, please make a few test calls to verify the outcome.