Symptom
When attempting to initiate an outbound call via Aircall's Public API using the endpoint /v1/users/:id/calls
, as described in https://developer.aircall.io/api-references/#start-an-outbound-call, you receive a success response for the request, however no call is initiated.
Cause
This issue may occur due to the requirement that the agent for the call must be in an available state on the Aircall desktop app. If the Agent is available only on the mobile app, they can be set to available and therefore no error response is received, however no call actually gets initiated as they are not available on desktop.
Solution
To prevent issues, ensure that the appropriate users are always using the Aircall Desktop app if you intend to initiate calls via Public API.