Symptom
Users encounter an error message that says, "Content is blocked. Contact the site owner to fix the issue" when trying to use Aircall CTI in Salesforce.
Cause
This issue is primarily due to a missing Trusted URL configuration in Salesforce. This causes the Salesforce security settings to block content from the Aircall CTI.
Solution
Please follow the steps below to resolve the issue:
- Log in to your Salesforce account.
- Search for and click on Trusted URLs in the Salesforce Setup console.
- Click New Trusted URL.
- In the API Name field, enter Aircall.
- In the URL field, enter
https://*.aircall.io
. - Check all boxes in the CSP Directives section.
- Click Save.
- Reload the Salesforce page.
After performing these steps, clear your browser cache and log back into Salesforce. This should resolve the content-blocking issue.
Additional Information
For more information on configuring Aircall CTI in Salesforce, refer to How To Configure Your Aircall CTI Within Salesforce Lightning. Additionally, make sure that the user emails match between Salesforce and Aircall for proper integration. If the issue persists, you could ensure that all the network and firewall settings allow connections to Aircall domains https://*.aircall.io
.