Symptom
When reviewing the call history in the Aircall app, you might notice that some calls display the agent who answered the call as 'Anonymous' instead of showing the actual name of the user.
Cause
This behavior occurs when the call history includes calls that were made or answered by users who have since been deleted from the Aircall system. Aircall retains the call records to maintain accurate call logs; however, if the user associated with a call has been deleted, their name will no longer display, and the call will appear as 'Answered by Anonymous' or 'Made by Anonymous.'
Solution
This behavior is expected and normal. When a user account is deleted in Aircall, the calls made or received by that user remain in the call history. The user?s name will no longer appear, leading to the 'Anonymous' label being shown instead.
If you have recently deleted several users in your system and subsequently see that calls are marked as 'Answered by Anonymous,' this is likely the cause.
To prevent confusion, it may be helpful to inform your team about this behavior and ensure that critical call data is reviewed before deleting users.
Additional Information
For more details on how calls are logged and displayed within Aircall, you can refer to related articles on the Aircall support site: