Symptom
Some contacts are visible on the Aircall application but they are not available to be found on the Public API.
Cause
Only Aircall contacts - created manually on the application or through the API in Aircall - are available on the Public API.
Contacts synchronised from integrations are only available on the Aircall application and cannot be retrieved on the Public API. Those contacts are saved as extracts in Aircall and are automatically deleted once you delete the integration from which they were synchronized.
Solution
When retrieving your contacts via the Public API, it is important to remember that any contacts synchronized from integrations will not be available in the API data.