Symptom
When calls are transferred internally from one team to another or from one department to the other, they appear as Anonymous:
Cause
This happens when there is a team assigned to a call distribution for a number.
Solution
Since the phone number is assigned to a team rather than a specific person, calls appear as anonymous. To fix this, it's recommended to assign the call to an individual user in the call distribution smart flow. This way, instead of seeing "anonymous," you'll see the name of the user who is making or transferring the call.
When calls from anonymous numbers are being forwarded to an external number
To ensure successful routing of calls from anonymous or unknown numbers to external numbers, these calls will now appear with the industry-standard default number +266696687 in the "FROM" field when externally routed. This approach helps avoid carrier-related call blocking while maintaining the caller's anonymity.