Symptom
A user is logged in to the Aircall iOS mobile application, but is not receiving inbound calls.
Cause
There can be several causes for calls not ringing in the Aircall mobile app, including an unstable internet connect, an out of date Aircall mobile app, or a user being set to unavailable in the app.
For iOS specifically, having notifications disabled for Aircall, focus mode being on, or SDK limitations may also impact inbound calls.
Solution
If an agent is not receiving calls, please ensure the following:
- The user is connected to the internet and their connection is stable
- Users may try switching from wifi to cellular data, or vice versa, to see if there are improvements
- Their app version is up-to-date
- Their availability status is set to Available in the app
- Notifications are allowed for the Aircall app on their iPhone
- Focus mode is not enabled on their iPhone
Note: Due to the mobile SDK restrictions on iOS, we can only ring users for 1 minute on the iOS app, regardless of if the ringing time was set for longer in the Aircall number's call distribution flow.