Symptom
When looking at the number of calls from Analytics and the public API, users are seeing different values.
Cause
The difference in the number of calls between Analytics in the Aircall Dashboard and the Public API is due to Analytics including call data from deleted numbers to provide historical insights, while call data from deleted numbers is no longer available in the Public API because those call objects no longer exist.
Solution
When taking a look at your call volume in both Analytics in the Dashboard and through the API, it's important to remember that any calls to/from deleted numbers will be excluded from the API data.