Symptom
Sometimes, due to possible setups of other services, inbound calls may not come directly into Aircall. The caller may call a non-Aircall number that forwards the incoming call to Aircall via a preconfigured setup.
When an external number is forwarding to Aircall, you may see that it is not ringing on the Aircall number.
Cause
For this scenario, when calls are not ringing/arriving to an Aircall number, it is key to rule out that there is an issue with the forwarding carrier to speed up a solution. Some actions that will help with the investigation of this kind of issue are:
- Checking whether direct calls to the Aircall number work or not. If they arrive at Aircall with no issues, typically the problem will lie with the forwarding itself.
- Checking with the carrier owning the non-Aircall forwarding number on whether they are seeing the missing inbound calls at all. If the inbound calls do not reach the forwarding number, they will not be forwarded to Aircall.
Solution
If the carrier owning the non-Aircall forwarding number confirms they are seeing the missing inbound calls and sending them on towards Aircall, please ask them to check with the next carriers in the call path where the calls are being blocked or misrouted and report the issue to Aircall as well to have the issue investigated from the receiving end too.