Symptom
- When attempting to send a message, an error is shown: "An Error has occurred, please try again later."
- You are sending messages from a US-based telephone number.
- Signing into the Aircall Dashboard (dashboard.aircall.io) shows that the number is "Not registered" as shown below.
Causes
- The main cause for this error message is your Aircall number isn't registered for either the Toll-free or A2P 10DLC registration that all North American numbers have to complete.
- You may be listed under the Outgoing Calls only for your Aircall number. ( Outgoing Calls Only and Aircall SMS )
- You may be attempting to send a message to a toll-free number, which is not supported at the moment.
- The Aircall SMS limit has been reached (What are Segments?)
Solution
The best way to check this would be via your Aircall Dashboard under Numbers. You will be able to select the Number in question and will see this message showing "Not registered".
Clicking on the Registration Status listed on the right will give you additional details about what is needed to enable SMS usage of the number.
For further information on the Number Status, please check out our handy guide: A2P 10DLC and Checking Your Number Status in the Dashboard.
If your number is showing registered via our Aircall Dashboard and the error message is still being received while you are not in the Outgoing Calls only section, consider contacting Aircall Support for more assistance.
Please include the specific numbers and users that are getting the error message and any screenshots that show the error message in question.