Overview
Some customers use Aircall via a Remote Desktop environment. This is typically done where a user logs into a remote machine to complete daily activities. This could include solutions such as Azure Virtual Desktop, or other similar technologies.
This article describes some of the problems that are likely to occur with such a configuration.
Symptoms
- Outbound Calls fail or are very latent over RDP
- Inbound calls are not received when the Aircall app is running on a Virtual Machine
Cause
The Virtual machine introduces additional overhead, and possibilities for network disruptions. Aircall needs a stable reliable connection for an optimal experience and this additional layer means that now the audio and additional data overhead needs to transverse the remote desktop client as well.
Solution
To implement such a setup, you would need a very high speed, reliable, stable internet connection at all times between your client and server. Aircall doesn't have recommendations on this, and would highly recommend deploying the Aircall app on the thin client directly as a preference and best-practice.
Any issues being experienced with call stability, or connectivity with a Remote/Virtual Machine setup should be replicated without this layer involved to help determine what might be the root cause. If you are still experiencing issues after removing the remote desktop element, please review: Audio, Network and Call Quality guides for more help and assistance.