Symptom
Users are suddenly seeing a lot of new, unactioned items in their To-Do section, and the bottom area of their app suddenly looks like this:
Cause
Two potential causes of this would be recently changing any of your numbers from IVR to Classic, or updating to the new Smartflows Routing
As detailed in our article about missed calls, missed calls will not appear in the To-Do section for users if the number in which they were missed on is set up as an IVR with the previous routing.
If at some point you decide to switch that number from an IVR to a Classic number, then all of the past, unactioned, missed calls and voicemails will be visible again, thus showing up in your app.
The same applies if you update an IVR number to the new Smartflows routing, as Smartflow IVRs do not have the same limitation with the To-do list as IVR numbers in the previous routing.
Solution
There are two ways to make these old alerts disappear:
- You can bulk archive the calls by clicking on the "Archive all" button.
⚠️ Please note: the maximum number of pending alerts that the app will show is 99, so if you have more missed calls that need to be actioned, you will have to repeat the operation and click on the "Archive all" button until all of the calls have been archived. For example, if you have 400 missed calls, you will still see the “+99” indicator after clicking "Archive all" once. - If you are unable to archive all of your calls via this method, you can contact our Support Team who will be happy to assist and archive all calls from their end.