Please note that this article is intended for technical audiences such as IT administrators.
Symptom
Cannot re-provision previously configured IP phones to Aircall.
Cause
Most major IP phone manufacturers have public-facing provision servers to which the phones are registered when sold. This allows the phone to autoconfigure itself when it boots up or is defaulted. The problem occurs when you want to reprovision the phone to another SIP Server, i.e. Aircall.io. The settings are constantly reloaded from the config file, and the manual settings for Aircall are overridden.
Solution
Yealink:
Yealink IP Phones are typically registered to the Yealink RPS server by the distributor that sells the phone. You must open a ticket with Yealink: http://ticket.yealink.com/, or if you have a distributor, you can talk to them and have them remove the phone registration from the Yealink RPS server.
Polycom:
You must create a MyHPSupport ticket to have the device removed from the Poly Zero Touch system. Visit Create a MyHPSupport Case for more information.
After you receive confirmation that the MAC address has been removed, add the device to your account.