Symptom
Users notice some inbound calls are not making it through, and the number that should be receiving the calls is not an Aircall number (was not bought through or ported to Aircall).
Cause
Generally speaking, inbound calls are routed to the carrier hosting the number. Hence, a call made to an Aircall number should arrive at Aircall, and a call made to a number owned by carrier X will go to carrier X. If a number is not hosted by Aircall, those calls will not come to Aircall but to the carrier owning the number.
Solution
One solution would be to buy a new number directly through Aircall, or to port the externally hosted number to Aircall.
This general rule can sometimes be modified however when using Bring Your Own Carrier (BYOC). BYOC is a way to change the routing so that inbound calls arriving at carrier X owning a non-Aircall number are sent from that carrier to Aircall. If interested in this feature, please check with your Aircall Customer Success Manager or Account Manager.