Symptom
Having recently updated numbers to the new Smartflows setup, inbound calls to one or more of your numbers seem to be instantly dropping.
Cause
One possible cause may be confusion with Smartflows call distribution configuration, and something important to check would be if your number’s configuration looks like this:
If it does, there is a good chance the dropped calls can be explained by this distribution.
In this setup, the number flow only contains one user, with no welcome message, no voicemail message, etc. Additionally, the only assigned user is set as “skip if busy." With this setup, if a caller dials the number while the user is either busy (in a call, in their set wrap up time) or unavailable (offline/logged out of their app, set to unavailable in the app), the call will skip them and immediately disconnect.
Because there is no welcome message or voicemail message, from the caller's perspective it will seem as if the call dropped because after dialing the number nothing was heard and the call disconnected.
In these cases, call are not necessarily dropped, but rather follow the set call distribution which may give the perception of the calls being dropped.
Solution
To help prevent these cases/perceptions, there are several thing you can do, such as adding a welcome and/or a voicemail message, or adding more users and/or teams to the call distribution. By adding these items you can increase the chances that someone will be available to take each call, and in the case that no one is available, allow the caller to hear messages/leave voicemails so they know their calls are connecting.