Symptom
Wenn Sie versuchen, einen ausgehenden Anruf über die öffentliche API von Aircall mit dem Endpunkt /v1/users/:id/calls
zu initiieren, wie in https://developer.aircall.io/api-references/#start-an-outbound-call beschrieben, erhalten Sie eine erfolgreiche Antwort für die Anfrage, jedoch wird kein Anruf initiiert.
Ursache
Dieses Problem kann aufgrund der Anforderung auftreten, dass der Agent für den Anruf in der Aircall-Desktop-App in einem verfügbaren Zustand sein muss. Wenn der Agent nur in der mobilen App verfügbar ist, kann er auf "verfügbar" gesetzt werden und erhält daher keine Fehlerantwort, aber es wird kein Anruf initiiert, da er auf desktop nicht verfügbar ist.
Lösung
Um Probleme zu vermeiden, stellen Sie sicher, dass die entsprechenden Benutzer immer die Aircall Desktop App verwenden, wenn Sie beabsichtigen, Anrufe über die öffentliche API zu initiieren.