Symptom
Benutzer erhalten die Fehlermeldung „Inhalt ist blockiert. Wenden Sie sich an den Sitebesitzer, um das Problem zu beheben“, wenn sie versuchen, Aircall CTI in Salesforce zu verwenden.
Ursache
Dieses Problem ist hauptsächlich auf eine fehlende Konfiguration vertrauenswürdiger URLs in Salesforce zurückzuführen. Dies führt dazu, dass die Salesforce-Sicherheitseinstellungen Inhalte von Aircall CTI blockieren.
Lösung
Befolgen Sie zur Behebung des Problems die folgenden Schritte:
- Melden Sie sich bei Ihrem Salesforce-Konto an.
- Suchen Sie in der Salesforce-Setup-Konsole nach Vertrauenswürdigen URLs und klicken Sie darauf.
- Klicken Sie auf Neue vertrauenswürdige URL .
- Geben Sie im Feld „API-Name“ Aircall ein.
- Geben Sie im Feld „URL“
https://*.aircall.io
ein. - Aktivieren Sie alle Kontrollkästchen im Abschnitt „CSP-Richtlinien“.
- Klicken Sie auf Speichern .
- Laden Sie die Salesforce-Seite neu.
Leeren Sie nach Durchführung dieser Schritte Ihren Browser-Cache und melden Sie sich erneut bei Salesforce an. Dadurch sollte das Problem mit der Inhaltsblockierung behoben sein.
Weitere Informationen
Weitere Informationen zum Konfigurieren von Aircall CTI in Salesforce finden Sie unter So konfigurieren Sie Ihr Aircall CTI in Salesforce Lightning . Stellen Sie außerdem sicher, dass die Benutzer-E-Mails in Salesforce und Aircall übereinstimmen, um eine ordnungsgemäße Integration zu gewährleisten. Sollte das Problem weiterhin bestehen, stellen Sie sicher, dass alle Netzwerk- und Firewall-Einstellungen Verbindungen zu Aircall-Domänen https://*.aircall.io
zulassen.